WTF Scopely? Give me the middle finger, is more straightforward


#1

Seriously, what the hell people. Three times before I have asked for help to retrieve my account and there was never problem with it. U all asked for information only the owner may check or know. But now I need a receipt to show it is “me” no matter how much information I give you that only the owner of the account(me) can give you? How many screenshots I took before changing phones too?

I have send screenshots which CANNOT BE FROM OTHER SOURCE BECAUSE I TAKE THEM IN THE DAMN IPHONE!!!

Yet, you ask me for a receipt? Is this you all giving the middle fingers to players to have been playing with you all since the beginning? To casual players?

I made it this far without buying a single goddamn coin from the store. I have never used real money to buy something in an APP! Hell, I never brought an app. I only use the free apps.

But, no. You need a receipt that doesn’t and CANNOT exist to show it is me?

Why don’t you all just go and say “you haven’t give us money so ■■■■■■■■”. That is more straightforward.

Seriously, why now of all times do you need to ask for a receipt and not before? Why didn’t you tell me the same method to retrieve my account was off before? My mail is bugged but you didn’t fix it and didn’t say anything. God damn it. It is christmas day, I already lost one of the 12 days of christmas even and am getting behind on level up and raid tournament because of this! I WAS IN 109 RANKING IN LEVEL UP LAST TIME! Now I must be on 320! God damn it. Just, please help me retrieve my account and stop asking for something that I.CANNOT.HAVE and accept all the goddamn information I have given that only I can know. I have been playing non-stop for MONTHS. I connect minimum two times a day. It is that hard to connect the dots that I have been asking you for help not even THREE HOURS after getting my new Iphone!? I haven’t connected again and continue asking for help in “contact us” and they continue saying that they need a receipt.

Something that they never asked me before when you needed to retrieve my account!

Oh? By the way. Can you fix your god damn “how to link a new account”? Because on IOS no matter how many times I delete and install the game again. There is no CACHE memory to delete. The Iphone continues with the same account. No matter what. I can’t link to another mail and TRY to see if it gets fixed. The only way to get it back is to reset the phone settings back to fabric then using a back up and install ALL APPS again. Which takes a hell lot of time! IT HAVEN’T EVEN DOWNLOADED ALL MY APPS YET. Not to mention apple ask for a confirmation from one of your working apple products which I only have ONE!

God damn it. Just help me please. Stop asking for the receipt I have given you all enough information to retrieve my account!


#2

They pretty much expect you to make a purchase so you can get your account back. Even for scopley this is pretty pathetic. Good luck getting your account back mate.


#3

If I read this correctly, you’ve lost your account 4 times total?

Is it not linked to Facebook or  Gamecenter?


#4

@kalishane and this is what makes us all salty…


#5

It is linked through facebook. But, at the same time. The first time I tried linking it to my facebook account it created a new camp. Since then, it always throw me there. I have asked for them to solve it and they say the issue was solved.

Every time, since then I have linked account and it drops me in the one I’m currently in. All the times they asked the same information for me to give them and some more but never a receipt.

The problem here is that my mail linked is bugged or something because I really only have three mails. Two of them says that they aren’t linked to any account leaving the one I always use to be the only true one.

Don’t really lost my account as much as the game throws me in this shitty account and not my real one.


#6

It is linked to gamecenter. But that means nothing because it always says the same: Welcome (my name) and drops me on the same level 4 town hall account.

Once more. I receive a message from scopely support. Without a receipt of a purchase in the game they cannot help me. Like the account password means nothing, like all the other information means nothing. Like my screenshots that ONLY I CAN TAKE mean nothing… Why wasn’t I asked for a receive the three times in the past? Why now? Why didn’t Scopely say they would change how to retrieve accounts in a general message? Why NOW?

Christmas day, fighting for them to recover my account. Which they continue saying I need a receipt… THAT I DO NOT/ CANNOT/ WILL NOT HAVE!!!


#7

Its probably because of how many issues you’ve had with needing to recover your accounts.Whatever ends up happening you should try and get them to delete the dummy account they keep sending you too. Instead they should add the one you actually use in place of the other one. I know how shitty scopley customer service is… so gl getting it back.


#8

I though they did so, they did told me it was fixed last time. But no, it isn’t. The issue on the whole account recovery happen every year or so because a new iphone comes out.


#9

… seriously? You are asking me to BUY something to recover my account?

“We will need a screenshot of an in-game purchase”

WHY didn’t you all ask me for this BEFORE? You certainly do not NEED it. You just want me to pay so you would help me. If you did it three times in the past, why can’t you do it now? What changed? Give me a clear answer and stop repeating the same shit aboye a receipt needed. Because I CANT ACCESS THE GAME ANYMORE.


#10

What part of:

I CAN’T give you a receipt because I never brought something don’t this people get? Then they have the gall to ask me to buy something else they can’t retrieve it?

How come they never asked for it before? Seriously. Answer.Me.Clearly damnit. What changed that made it so I cannot recover my account if I don’t BUY coins!?

Can’t you just check with gamefuckingcenter? Can’t you check with the fucking apps store account!? Why can’t you JUST CONNECT THE DOTS! I left the game a few hours before changing phones and asking for my account retrieval. I gave fucking screenshots, I gave information. I gave everything and they continue saying the same thing I cannot give them!?

What kind of retarded system is this!? You’ve are telling me you just changed the way to retrieve accounts in a year or less!?

Fuck, I can ASK for my faction mates who I have a WhatsApp group to GIVE YOU ALL CLARIFICATION! I cannot change phone number and I have been a proud member since years! You CAN’T fake two years of conversation with pictures and more than 12 people talking to each other through WhatsApp! It.Is.My.Account.

I gave enough fucking evidence, things only the owner(me) can know yet they need a receipt!?

All this bullshit on CHRISTMAS DAY TOO!


#11

@Betoran - I hope they fix this. I play other games and have never had a problem changing phones - I use my google account and the game application just loads 100% of the time every time. I guess the Scopely folks have not figured out how to do this very simple thing.

Shame Shame Shame.

image


#12

Seems I will fucking be another person to leave the game. They can’t retrieve my account cause I never brought something from them. All because of an error THEY SUPPOSELY FIXED!

Look at that message. Asking me the impossible. Buy something? Yeah. Let me just enter in my account and buy something… oh? What is this? Level 4 town hall shitty account? Will it counts if I buy from here? Probably. They are money hungry after all!

They aren’t telling WHY! Why did they let me retrieve my account last time with random data about the account only the owner would have know but now they can’t!?

Why isn’t any ADMIN from the page answering me!? Help me damn it! This is my forum account and was since I joined the forums!(the last forum which was different).

I gave them my account code. That in itself should be brought because only the god damn owner of the account would know the code! Hell, it isn’t hard to notice how my perfect daily connection suddenly failed because they haven’t GIVE ME MY ACCOUNT.

More so now that we are in a fucking daily 12 days of Christmas event! But noooooooOoOooo. They need a receipt that I cannot and will not have!


#13

I’m really sorry this happened to you. What’s the point of an account code if you can’t use it to verify your account? Anyway, look on the bright side: this is your best opportunity at leaving the game with nothing to lose.


#14

Everything on Christmas day too :smiley:


#16

… haha…ha.

Scopely support at its finest. Seriously, haven’t gotten a single problem in my others apps but THIS one? Then support CAN’T fix it cause I can’t give them a receipt?

Seriously, now even Paraguayan Police is this corrupted. Not even Bolivian or Brazilian!

I find it funny how all the moderators and/or admins are just ignoring me and don’t respond.

Have spoken to more than 6 different ‘support’ people. All of them say the same and can’t really have a normal fucking conversation with one of them.

They are saying they “cannot bypass the process”? Then WHY DID THEY DID SO THREE TIMES IN THE PAST AND WHY DIDNT THEY SAY THEY CHANGED THE WAY ACCOUNT RETRIEVAL WORKS!?

That “thank you for understanding” at the end though? That shit is HILARIOUS! Because I understand NOTHING! They haven’t answer me! Why didn’t they fu**** ask for a “receipt” in the past but do so now!? Fuc**** retarded AND corrupted people!


#17

I would look at it as hey you don’t spend so why should we care attitude.

I mean that’s how I take it. Have you considered playing a different game?


#18

Not many games with “auto-attack” and zombies bro.

Not to mention, four years and a half in this shit? You telling me all my effort is gonna go down the toilet because of something they said “fixed” but didn’t? This is THEIR fault. They told me it was fixed the last time when I asked them to do so because facebook link threw me to that level 4 account.

They said fixed, they didn’t fixed it. Now Imma paying for THEIR mistake and they will not even say sorry or give me my account OR give me a clear answer of WHEN AND WHY did they retrieve my account without a receipt in the past(not even a year even!) but can’t now?


#19

Have you spent money on this? And also this game hasnt been out for 4 1/2 years.


#20

… dude. 4 years AND something months. Maybe three or five months extra I don’t know. I just know it was four years since I was in second year in school when I discover the APP. Which I used to just leave under desk in auto-play. Maybe it was three years and 10 or 8 months. Dun’t really care. It was four something.


#21

Yes 2015 was 4 years ago