Trouble loading game

Hey, I’m having trouble logging into the game it keeps saying my internet is down but it’s perfectly fine ???

1 Like

Same problem here and during war smh

Exactly the same here too!

A faction mate and my hubby are getting the same error. Neither can get into the game to contact support.

Rebooted phone, rebooted game, cleared cache, reinstalled. Nothing works

The last two times he cleared the game cache a 182 mb update downloads each time. The dowload gets stuck at unpacking and then the internet connection error occurs as well.

Mine has two different error messages depending on If I try with WiFi or Data… really annoying. Need to help my crew in war!!

I managed to sort mine I deleted the App and reinstalled it

Did the same thing and has fixed it, thank you.

Fixed hubbys.
Turned off all wifi.
Then uninstalled game.
Cleaned storage and memory
Then rebooted the phone.
Turned wifi back on
Reinstalled game

Works now

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.