Purchase Error 300,004


#1

Having an issue buying gold with Amazon coins. Screen flashes black and says Error 300,002

Please help.


#2

Bump… Is this happening to anyone else?


#3

are you playing on a mobile device or your pc?


#4

I started getting error 300,004 several days ago when trying to buy anything from the store, tried support who as usual were totally useless just sending a typical copy/paste auto response. I was wondering if anyone has had any success in resolving this error or am I just never gonna be able to make purchases any more?


#5

image


#6

I’ve been getting this error for the past week. Please fix.


#7

I’ve been getting the same issue for a while . Any attempt to purchase through the Amazon app is not working .
Saving me a fortune :slight_smile:
But it needs fixing before the Lori level up event ends


#8

same here - I’m getting error 300.004 when trying to purchase coins via the Amazon app game installed - I think this bug showed up after the last update? I already tried to un-reinstall the game, cleared cache. Still waiting on a response from support - but my expectations are low to actually get a solution.

My google store game app works fine - no errors.

Update - just received this response from support


update 5/23:
talked with Amazon tech support via chat, they have now escalated the issue to the technical team. Please allow us 48 hours to fix this. Once done we would even notify you via email. You can always use the id to contact us am track the progress of the fix.

I asked if I have to wait now - response: Yes please. It could be an issue on the server end which has to be fixed from our end and it takes some time to get the bug on the server and your account level. Please tell players to wait for 48 hours. I have added details that the issue has been affecting multiple accounts. So the team would look into other accounts as well


#9

@kalishane @CombatMan @CombatDevIl any idea how to fix this issue?


#10

Best. Error. EVER!


#11

Would really like some info on this bug cause its getting ridiculous now, I’m now on my 7th day (or is it 8th? I’m losing count now) of not being able to make any purchases in the store and its beyond frustrating. I would have thought a bug that’s costing them money :moneybag: would have received a fix by now or failing that some sort of official word on what’s happening with it. :angry:


#12

I’m having this same error, please help!


#13

For those buying from Amazon and getting this error - I had to contact Amazon support to resolve, since I contacted the App store support its been working fine but it doesn’t resolve the situation in a timely manner


#14

via Imgflip Meme Generator


#15

Thanks for that info, I’ll give that a try.


#16

Bump. @kalishane


#17

Same here. A faction mate, that was getting this error too, finally could buy his monthly pass following these steps: twd:rts app - wipe cache, wipe data, uninstall; amazon appstore - wipe cache, wipe data, uninstall; reboot device; install amazon appstore; install twd:rts; cross fingers (important)

I think I didn’t cross my fingers strong enough because I did this several times and I’m still getting error 300,004


#18

Bump - same error here. Customer Service said to clear cache and data. Did this and still the error. Then they said it is Amazons fault.
Called Amazon, they checked everything, said the error is on scopely.

Please help @kalishane!

I am very sad.


#19

Finally I could buy coins via Amazon using an old Android device wich I reset to factory defaults. Everything worked fine at first try. Maybe the Android version of some devices is causing the issue? :man_shrugging:


#20

I could fix this problem on my Android, by re-installing the RTS game and running the tutorial again.

Several iterations of cleaning the cache or data from AmazonAppstore and the RTS App did not help me.

This is a very poor service = no service from customer support or any official reps here on the forum.

Thank you to the community for listening and contributing and helping me.