Pixel 3 XL (Android Pie 9.0) - Stuck at Tutorial

bug

#1

@JB.Scopely

I just got the new Pixel 3 XL that just came out. Installed the game and tried to go through the tutorial so I can link to Facebook to load my saved game from another phone.

But cannot as I am stuck at a screen in the tutorial. For some reason, at the screen for Leveling up Rick, it won’t let me press X to close it out once the leveling up is complete. See screenshot below.

Pressing on the X like the instruction says won’t do anything. I tried to press many times at different areas in the corner of the screen but it doesn’t work. I know the screen touch works fine because I close the game and touch that area and it works fine.

Tried clearing cache, uninstalling the game, stuck at same area. Please help fix this bug as I can’t load my saved game and play… Thank you!

Brand new phone.
Pixel 3 XL - Android 9.0
latest version of the game 10/19/2018


#2

I can confirm exact same issue with me on my PIXEL 3 XL I setup today.


#3

Yea it sucks. Hopefully this will get fixed asap…

Let me know if you find a way to click out of it…


#4

Have not figured out a work around. Tried several troubleshooting steps but unable to bypass same spot.


#5

It’s late on a Friday night in JB’s time zone, he doesn’t work weekends, and even if he did he has no ability to fix an issue. All he can do is notify other people. Please open a ticket with customer support and if there is a fix available they’ll help you through it. If you can’t get to the support in game because of this issue, you can open a ticket via the web at https://scopely.com/customer-support.


#6

Google changed the display frame work in Pie, and app developers would need to make sure their apps are coded properly (usually the app incorrectly assumes a fixed width of the status bar, which should be dynamic).

Try to press some milimeters on the left to the x


#7

Yea I tried pressing everywhere on the edges, left, right, but no go. Thanks though!


#8

Thank you LadyGeek!


#9

Same problem here :frowning:


#10

Bump for @JB.Scopely - please submit this bug to your team. I contacted Scopely support to submit the bug but got this as a reply. They are truly clueless. They think it’s a connection issue? sigh…


#11

Any word of a timeline on a fix @JB.Scopely ?


#12

I’m going 2 weeks with a similar problem, I’m stuck in the tutorial a pop up comes up saying that transfer was suscesfull and I can’t click on “ok”. Good luck getting this fix in any reasonable time, I missed logging collection, 3 year tokens I had 75 and this crw my faction came in first and I miss finally getting glenn from the museum.


#13

Hello,

Sorry I missed this thread until now.

I’m sad to see such a new gorgeous device having issues with the game :frowning:
Although, it is rather common that a new piece of hardware, that is yet to be optimised for an existing app or game, require some minor code tweaks to ensure a full compatibility.

I will have our technical staff look into it now, and I hope you have an older device handy in the meantime, as this could require some heavy lifting in the game’s code, along with a new client update.

@Ronald - you do have a complete different and unrelated issue here, that would need to be taken to our support crew for attention.


#14

would it make sense to simply add a “SKIP TUTORIAL” button??? so people dont have to go through it each time they start on a new region or want to use a new device?


#15

Actually it has been recently implemented to tackle the issue Ronald mentions.

We’ve dealt with a bunch of players stuck at the tutorial popup stating ‘Transfer is now complete’ earlier on, which we have then decided to make this popup ‘discardable’ not to lock the player in this state when this occurs.

That is why I’m surprised to see further reports, and invite players to take it to support for further investigation on this.


#16

Quick update on this front: we’ll have full compatibility with the device with the next game update.


#17

Skip works by skipping the story part, what I think he means is that you can skip the whole tutorial and just load player lv1 ready to do roadmap 1.

Check this video I made sure my button presses show

This is my last reply from support


#18

Thanks for following up on this JB. Much appreciated.


#19

I too was having the same issue with my new Pixel XL 3. Noticed how I said “was”.
Here is a temporary fix that I found while messing around with some settings. This should help Pixel 3 users until the new update is released…

First, unlock the hidden Developer’s Options. This is done by going into the phone’s settings. Then select System. Then select About Phone. Then scroll all the way down to the bottom where it says Build Number. Click Build Number 7 times or until it says you’ve unlocked it. Once you’ve unlocked it, then go back to the System setting. Then select Advanced and then select Developer Options. Then scroll down until you see the option Display Cutout. Select that option and change the setting to Hide. Back out and retry the game’s tutorial. You will now be able to click the X and continue with the tutorial.

You should notice now that your display does not wrap around the cutout on the screen where the camera and ear speaker are. It is now replaced with a black bar and squares off the display. You must keep it in this setting while playing the game in order for it to function properly and not get stuck on other screens. You can change it back to Device Default whenever you want, but must have it on while playing TWD. Like I said, this is a temporary fix. Hopefully, the new update repairs the issue. Beware of making any other changes in the Developer Options, unless you know what you are doing.

Hope this helps. @JB.Scopely
Fulano out.


Game update for Pixel 3?
#20

That is awesome tinkering, thanks for that!