No milestones reward

my score is currently at 900k but I havent received any milestones reward…

Did you use veteran rings?

Yeah, first time ive tried it…

There’s a bug when you use rings you get the points but not milestones. Open a ticket with support and be prepared for them to be unhelpful and it to take a long time for it to get fixed :sigh:

6 Likes

Don’t use vet rings to cross a milestone, they are still bugged

I just had this… Took a few days. At first they said I already received it. Later they told me I received them but gave the date of the previous level up tournament. Its really frustrating but keep at it eventually they will hand them out…

Try lvl up toon with trainer, other toon.

Im ur fan(?

I had same issue previous level up event, support helped me and I got my rewards

I’d just rip them unless you want a battle.

I just gave up after three tickets. Lesson learned.

Workaround:
Level a toon nornally, after the veteran leveling and then it counts everything.
At least for leaderboard. Not sure about milestones

Do you really think we didn’t know that

Fuck, i just used rings and passed 500k. No milestone :man_facepalming:t2::man_facepalming:t2::man_facepalming:t2:

It’s pretty ridiculous that this is still an issue and veteran rings have been out for months.

5 Likes

Veteran rings should not give points at all. Problem solved.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.