New update is not compatible with device

Is there a reason why the new update would not be compatible with my device? In game it says it needs to be update. When I click ok it takes me to Google play store but says it’s not compatible.

7 posts were merged into an existing topic: New Patch Update Compatibility with Samsung Phones