Is anyone else still waiting on draft rewards

Does anybody else’s arena show this on their Draft and are still waiting on their rewards? I think I’ll need to open a ticket by the looks of things, as I see no other mention in forums about this.

1 Like

Yes, same thing. Been nearly 48 hours and still no rewards. I sent a message to in-game support, but have not heard back. I was #19 so I’m missing out on quite a few league points. I’m on Wilcox.

I never even noticed until a teammate mentioned, lol. I got them elsewhere, but not on my main, which is in Autauga. Seems to be a random bug, I’m going to send a message just now, even if it is for crappy rewards.

Yeah, there’s another member in my faction experiencing the same issue. Hopefully it’s fixed soon because it’s setting off my OCD lol

Haven’t got mine either.

Mine’s missing as well :pensive:

1 Like


Still waiting

Same issue here, I contacted support and they told me rewards will be in my inbox within 24 hours

Just noticed it when I checked my supporter finish. Same deal.

I was told that too…exactly 25 hours ago

Ok scopely, wtf. Got my supporter rewards, but still haven’t received my draft rewards


Time to message support again😑

Yeah, looks like I got the rewards from the arenas that ended today but yesterday is still missing in action. Guess I will send something to support I was waiting 24 hours before I did

I’m waiting on my 2.1m level up milestone rewards, which is causing my Rubix mission not to be met, and will end in 4 hours. Think something is wrong at the moment in issuing rewards generally.

Have you updated the game to the latest version? I believe I’ve heard some people needed to have the game updated and then some of the missing rewards showed up.

But the draft rewards issue is a separate issue that seems to be wide spread

I just restarted and after 5 mins, all my level up and draft rewards appeared. Unsure if it was related to restart game or not but it’s sorted now, for me at least

Correction: my draft rewards had appeared previously, it was just my supporter squad arena rewards that only just arrived.

Re-correction: i have no idea if my draft rewards ever arrived or not. Meh.

Apple Store shows it is updated. Restarted the device and still not a thing. This is new territory for me never had an issue like this

Is your issue only not getting draft rewards because that’s a wide spread issue. The updating game version was for missing level up and rubix cubes.

If under draft it shows you a set of rewards it’s likely that you received them but if it says “your rewards are being sent, check back shortly…” then you probably haven’t received them which is the same boat most players seem to be in.

I haven’t gotten my milestones and rubix cubes either. My game has been updated and I restarted the app

This is what mine looks like on my baby account. On my main account it came through without an issue. Weird