Game won't load after 5/18/2018 update ***RESOLVED***

Game basicly freezes and won’t load town icons.
Changes screens sometimes very slowly, i.e. daily rewards tokens ready, 30day coins…

Unresponsive to any touch or extremely slow.
Have uninstalled and reinstalled multiple times.

Any suggestions?

1 Like

Been sitting, resetting, app, tablet, and reinstalling for near 36 hours

Don’t have a fb account… installed it to 2 other devices, started new games. Don’t wanna clear cache, bc of the same reason you highlighted. Haven’t tried an emulator tho.

This exact thing happend to someone in my faction right after update

Hey goat, pest here. You still in dead inside?

I’m from Hart region

My bad, had a thegoat1 in cowetta too

SStill the same

Dam that sucks man please post if you come up with a solution to this or if you hear anything from scopely about it

I have a faction mate with the same issue. Android, not beta.

Of course impossible to send ticket to CS.

Issue finally resolved after near48+ hours.

Had to create a FB account. Had agonizing wait times for tablet to respond. Linked account to FB, got to install it on another device with original account.

Haven’t tried clearing the tablets cache and seeing if it will work on the original device, BUT do have access to account again.

Is the tablet really cheap?
Potentially, updates could have made it so the device can barely handle it.
SWGoH became unplayable on my ipod 5th gen after constant updates.

1 Like

It’s an ASUS, but it is like 7+ years old and rooted

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.