Faction Supporters not working?

Anyone else seeing problems when using faction supporters?

When I select a faction supporter, they frequently (but not always) don’t show up on my team. They also often show as being available immediately after I’ve attempted to use them, so basically the game is ignoring my request.

The success of the selection depends on how they’re selected. Up until now, I just selected the supporter I wanted to use, and then pressed “attack” - this no longer works. However, if I select the support I want, then press “apply”, then “attack”, it works.

So basically, changes in the code are now requiring me to press an extra button every time, even though it worked fine the way it was before.

Is this an intentional or accidental change? Do you know if it’s going to stay this way?

1 Like

It was a bug before, that is the “fix”. Dev said.

Click apply then attack. Stupid extra unintuitive step added for no good reason.

3 Likes

@Agrajag
@CombatDevIl

Can you all remove this need to press apply? If it shows and you press attack, this should be sufficient.

With 9.3 release your sure to see a bunch more threads. No wants more clicks when farming…

4 Likes

100% makes sense so it won’t happen.

After dealing with this all weekend I am getting used to it, regrettably.


The new way is not intuitive. Why change it after several years and no complaints about it? The focus should be on the issues that people actually have.

5 Likes

Because it was allegedly broken all along. Just no one noticed.

For two and a half years…

2 Likes

the salt you can already taste it… haha, please just remove the apply button… just select and then attack…

Faction support working fine for me. It is kind of annoying having to apply it now. I was only use to it with items.

touche apply then go To thé scene

1 Like

This process has always applied to items. It was terrible there and I use faction supporters more than I use items :frowning:

Since you’re cleaning up “bugged” code, can you copy the SR code for the material pop ups (press ok, box disappears but you’re still in SR) and replace the everywhere-else code for that pop up (press x to close and stay where you are, press ok to be forcibly returned to town).

And un-f**k the faction supporter code, the less taps is better for this type of process.

1 Like

The issue is
@Agrajag
@CombatDevIl

Character is displayed in the lower right and attack button is active. Intuitively this says its locked and loaded.

Either

Make is so character is not shown until apply is pressed so it doesn’t look like you are ready

Or

Move it back to the way it was (preferred)

If I didn’t want that character there I would just x out on his portrait. What was wrong with that?

3 Likes

exactly…

Scopley ↓↓↓↓↓↓

I was just coming to complain about this bs!

It’s not working in Marion region either tried on world and road maps

I will never understand scopelys thought process on certain things! It drives me mad why muck up something that worked perfectly fine for the last 2 and a half years! Jeezus monroe!!

Kinda like how they also had to “fix” the crit rates.

Scopely always needs to “fix” things that don’t need fixing. Keep Surviving!

1 Like

I select a faction supporter and even though it is selected does not actually show up in roadmaps during play. I have a video where do I send it. It won’t let me send it won’t let me upload.

1 Like