Developer's- Why when raiding does it sometimes uncheck


#1

Not sure if it’s a bug or just something really annoying on purpose.
1st thing is I raid fast not auto most times so I know who I’ve selected
2nd it doesn’t happen all the time while attacking as to why I’m not sure if it’s a bug but it happens more often then not.
3rd it always happens, the unchecking of selected character, after using one of my characters AR
I’m going to explain best I can

So while raiding I’ll check a character to hit 2nd even 3rd round, while tapping, I usually go left to right in order, sometimes on purpose I’ll use a characters AR and it doesn’t kill the character. So I’ll hit the next attack button in my attack (I know my AR won’t kill the selected toon as to why I’m still clicking fast) but instead of my character hitting the character that I had select previous hit, it’s back to random.
Sometimes I’ll catch it before the next characters are pushed to attack but most times I’m clicking to fast. So is this on purpose or a bug? I know I’m not hitting the screen in the wrong spot after the AR attack, so it’s not from that clearing the selected character, plus it happens way to often.
My phone is a pixel XL latest update game and phone.


#2

I have that, too. I‘m convinced it‘s my fat fingers misclicking.


#3

I’ve also had this,I thought it was me I don’t auto in raids either but scrolled on a toon and a few times it just went random after I hit the toon After one hit,I’ve also noticed when I’ve selected a toon to hit after 5 hits if he still not dead he comes at me then when it’s my turn again the marker for the toon I selected has gone and back onto random again, I thought this was just me.


#4

This happens to me regularly, though I’m not by any means certain whether it’s a bug or me touching the screen delicately.

@Agrajag @CombatDevIl ?? Any known issue?


#5

This has always happened to me too for a long time in addition to the more recent bug where the game often causes my toons to shield (As though I swiped) when I tap the toon attack buttons.

I think it’s because there is no ‘dead zone’ around the toon attack buttons, so if you don’t press them exactly (big fingers on a small phone screen), your finger may touch the area just outside the button first and cause the target toon to become deselected.

It needs to be changed so that if you touch the area close to the buttons it has no effect. If you purposely want to deselect the target toon, you should have to tap somewhere in the game area above the buttons.

If this happens on your last attack, it can sometimes allow an enemy toon to AR when they would have been killed (the auto attacks a differeent toon or you end up shielding instead of attacking.)


#6

You could be right although I play on an iPad so big screen and always thought have I missed the toon button and hit the screen by accident


#7

I too have this problem. The odd thing about it is that even if I am going after the same target, it un-clicks the target I just attacked. I remember not long ago, was not like this. The target you hit stayed selected until it was dead. The tinfoil hat wearer in me suspects that it is a “feature” to add more rng into the game, thus making attacking less precise so you have to pay attention.


#8

It’s been like this awhile for me and I haven’t asked about it because I usually still win but now it’s making that I lose more often than not.
Anyone word on this Dev team?


#9

Yeah I feel like this is largely a tap precision thing. I know at least once in the past we tried widening the dead zones but that had made attacking less reliable or something? @CombatMan might remember better than I do. At the very least he’d know if there’s something related to the inadvertent deselections in the known issues bug pile.


#10

Why not change it so that you have to tap the current selected toon again to remove the selection and go back to auto choosing? This will make it difficult to accidentally unselect the target without intending to.

Most experienced players will always select their target anyway rather than rely on the AI which often makes poor choices.


#11

Do you guys tap through the AR animation. If so you might be tapping the dead zone while trying to tap through the animation. I know that has happened to me so many times. So frustrating.


#12

The times when I’ve noticed deselection in my own testing are after using an AR, because you can tap the screen to skip the AR animation, which I usually tap multiple times, which would cause the deselection of the enemy. I’d just be careful when skipping through the AR animation.


#13

This might be it, maybe I’m not noticing the extra tap. I’m going to try and pay more attention next time.
Thank you for the reply devs.


#14

I have had toons getting deselected when no AR was triggered, but I think this is probably because my finger touched the area just outside the button before the button itself (easy to do with big fingers on small phone screen.)

It would be much better if you had to tap the selected toon again to deselect them rather than anywhere on the screen. Most players except beginners would always choose a target anyway except when an easy fight that can be autoed.


#15

I’ve logged an enhancement to have the selection space at the bottom of the screen where the character icons are to not cause deselection of enemies.


#16

Thanks - that should help stop accidentally deselecting the target.

Hopefully the bug with the over-sensitive swipe to defend can also be fixed in the next upate: Over-sensitive swipe to defend bug is back again in 9.1


#17

Can we get rid of the AR animations all together? Maybe be an option in the osettings area. I too have had this happen a lot.