Davie's search, stage 5

#1

Has anyone beat it? I keep getting the victory screen but then game crashes. Energy isn’t consumed but can’t proceed beyond this stage. Happened 4 or 5 times, even after rebooting the game. Wondering if its just me

Edit: happened to many others in my fac and region. Solved by playing the stage manually and not on auto. Go figure…

1 Like
#2

You could try clearing the games cache. Method varies by device.

Edit: just make sure you have all your account details in case it deletes data on your phone.

#3

1 Like
#4

#5

@LaraCroft Thanks for the report! We had several reports of players having the same issue. Did you try to complete the stage in manual battle instead as it seems to do the trick?

1 Like
#6

Yes, manual worked fine, and after that the rest of the stages were fine with ayto

#7

I beat it on auto but it took 3 to 4 minutes before the completed came up

#8

#9

Someone chose Ajax and Davie lol

#10

1 Like
#11

Lmao! Really?

#12

I thought this whole thing was ridiculous until I saw that option. I don’t see how you don’t choose Ajax.

1 Like
#13

Lmao I just hope it carries to Davies finale

#14

closed #15

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.