Arena access problem

I have a fac mate who says he can’t access arenas. Is there anyone else experiencing this problem, and does anyone know why this might be?

I had one this morning, but I don’t know why

What happens when he tries to access arenas? Has he opened a ticket with support?

Its telling him there are no arenas available

Is he on a very low level account (I assume no, but just figured I’d ask)?
Has he tried switching from cell data to wifi or vice versa (not always possible but worth a try if he can)?

He is lvl 109. He is trying the switch to wi to now. Ty for your help, Lady G

Switching to wi to did not work. He is going to switch off de ice and see if that does anything

level 109 is plenty high enough. Last suggestion is to check play/app store for any updates and confirm the installed version is 21.something. And, of course, open a ticket with support.

Same here. No arena available. Support about as useful as a chocolate tea pot.
Tried everything and nothing helps. Im on the latest version. Tried raiding first, switched to WiFi and 4g, turned on and off (my favourite) but nothing. Lvl 150, by the way.

I had that when the event first started. I ended the game and re-started it.

Thank you for the help everyone. He went to WiFi and restartedde ice and is now able to access arenas

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.