Amazon game app


#1

When trying to open the game it says it needs the new update but when I hit the update button in game it goes to Google play store even though it is Amazon game download. If I go to Amazon game store it has no update.


#2

Same thing happening with my iPhone.


#3

Mine downloaded the apk file. I’m no expert but maybe it’s because you’re not using an Amazon device? It’s sorta like when I do an offer that requires an app that’s on GPS but not in the Appstore and instead of taking me to the Google store, it takes me to the Appstore.


#4

Had to go into folders delete the update from the other day, hit the update again, go back to folders and when done downloading open the file. Took a couple tries first couple times popped up with the picture below third time it worked.
I’m on Android.


Also thank you Tony821 for steering me in the right direction.


#5

Happened to me to. Update via the amazon app. Worked for me.


#6

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.